A left rotation operation on an array of size shifts each of the array's elements unit to the left. For example, if left rotations are performed on array , then the array would become .
Given an array of integers and a number, , perform left rotations on the array. Then print the updated array as a single line of space-separated integers.
Given an array of integers and a number, , perform left rotations on the array. Then print the updated array as a single line of space-separated integers.
Input Format
The first line contains two space-separated integers denoting the respective values of (the number of integers) and (the number of left rotations you must perform).
The second line contains space-separated integers describing the respective elements of the array's initial state.
The second line contains space-separated integers describing the respective elements of the array's initial state.
Constraints
Output Format
Print a single line of space-separated integers denoting the final state of the array after performing left rotations.
Sample Input
5 4
1 2 3 4 5
Sample Output
5 1 2 3 4
Explanation
When we perform left rotations, the array undergoes the following sequence of changes:
Thus, we print the array's final state as a single line of space-separated values, which is
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
int main() {
int n,r ;
scanf("%d %d",&n,&r);
int a[n],b[n];
for (int i =0; i<n;i++)
{
scanf("%d",&a[i]);
int l;
if ((i-r)%n<0)
{
l=(i-r)%n+n;
}
else
l=(i-r)%n;
b[l]= a[i];
}
for(int i=0;i<n;i++)
{
printf("%d ",b[i]);
}
/* Enter your code here. Read input from STDIN. Print output to STDOUT */
return 0;
}
5 1 2 3 4
.#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
int main() {
int n,r ;
scanf("%d %d",&n,&r);
int a[n],b[n];
for (int i =0; i<n;i++)
{
scanf("%d",&a[i]);
int l;
if ((i-r)%n<0)
{
l=(i-r)%n+n;
}
else
l=(i-r)%n;
b[l]= a[i];
}
for(int i=0;i<n;i++)
{
printf("%d ",b[i]);
}
/* Enter your code here. Read input from STDIN. Print output to STDOUT */
return 0;
}
No comments:
Post a Comment